Palette de Commande de Guitar Pro 8

La Palette de commande est un outil qui vous permet d’indiquer directement ce que vous souhaitez éditer ou modifier dans votre partition, ou l’action que vous voulez exécuter, à l’aide de lignes de commandes.

Une fois son principe assimilé, cet outil pourra grandement améliorer votre rapidité d’édition et, de manière générale, faciliter votre utilisation de Guitar Pro.

Accès

La fenêtre Palette de commande est accessible via le menu Outils > Afficher la palette de commande ou via le raccourci clavier Ctrl+E.

Elle apparaît au-dessus de votre partition, sous la barre d’onglets des fichiers ouverts dans Guitar Pro.

Accès à la palette de commande

Fonctionnement

À l’ouverture, la palette de commande apparaît vierge de commande, et vous êtes invité à renseigner l’action que vous souhaitez effectuer.

La mention “Type ? to show the commands list; up or down to browse the command history” apparaît.

Ouverture palette de commande

À ce stade, vous pouvez soit renseigner le préfixe qui vous permettra d’utiliser votre commande (la liste des préfixes est développée plus loin dans ce guide), soit taper un point d’interrogation pour afficher la liste des préfixes et commandes disponibles.

Liste des commandes

Notez que vous avez également la possibilité de renseigner manuellement tout ou partie du nom de l’élément recherché.

La liste des préfixes liés à votre recherche sera affinée, vous permettant ainsi d’accéder directement à la commande concernée (voir Recherches et filtres intelligents plus bas).

Les flèches Haut et Bas vous permettent de naviguer dans cette liste et de passer en revue les différentes commandes. Cette liste est classée dans l’ordre alphabétique.

Remarquez que certains préfixes et leur action apparaissent grisés, quand d’autres sont affichés en blanc.

La disponibilité de ces actions dépendra de votre sélection dans votre partition.

La liste de gauche reprend l’ensemble des préfixes à taper pour accéder à une commande, et celle de droite la description de la commande.

Un préfixe donne accès à une commande, qui générera une action dans Guitar Pro.

On distingue deux types de commandes.

Les commandes rapides (utilisables immédiatement) et les commandes avancées (qui nécessitent de renseigner un complément pour être utilisées).

Ces points, ainsi que la création de commandes à travers des exemples concrets, sont développés dans les paragraphes suivants.

Les préfixes et commandes de la palette de commande seront systématiquement affichés en anglais, quelle que soit la langue appliquée dans les préférences de Guitar Pro. Cependant, une traduction interne vous permet de rechercher vos préfixes en fonction de votre langue. Par exemple, si vous utilisez Guitar Pro en français et renseignez le mot “accord”, le préfixe “chord” vous sera proposé, ainsi que les options liées à ce préfixe.

Commandes rapides

Les commandes rapides sont des commandes qui peuvent être utilisées directement et pour lesquelles il n’est pas nécessaire de préciser une valeur ou une action complémentaire.

Ce type de commande équivaut à sélectionner ou désélectionner une icône dans Guitar Pro qui aurait une action immédiate.

C’est le cas, par exemple, pour l’application d’un palm mute.

Renseignez simplement tout ou partie du nom de l’action recherchée, ici “palm” dans le champ de recherche ; le préfixe palm-mute apparaît dans la liste des résultats disponibles, vous permettant d’utiliser la commande Set palm mute.

Palm mute depuis la palette de commandes

Utilisez la touche Tabulation, la touche Entrée, ou cliquez sur la proposition en bleu pour compléter la commande.

Palm mute depuis la palette de commandes

Validez la commande avec la touche Entrée ou en cliquant sur l’action proposée.

Notez que si un palm mute est déjà appliqué à votre sélection, il vous sera proposé de le retirer.

Mais ces commandes ne se limitent pas à l’édition.

Par exemple, l’utilisation de la commande Print Score via le préfixe Print équivaut à un clic sur l’icône d’impression.

Impression depuis la palette de commandes

Il existe au total 32 commandes rapides qui peuvent être utilisées depuis la palette de commandes. Celles-ci sont listées en fin de chapitre.

Commandes avancées

Contrairement aux commandes rapides décrites précédemment, les commandes avancées sont utilisées de pair avec une autre valeur ou nécessitent de préciser leur action.

Elles vous permettent d’exécuter des actions plus complexes, comme éditer des bends, ajouter des mesures, des patterns de coups de médiator, de brush, etc.

Une commande avancée se compose d’un préfixe et d’un ou plusieurs arguments, qui sont des informations complémentaires venant compléter la commande d’origine.

En fonction de la commande utilisée, l’ajout de ces informations complémentaires (ou arguments) peut se faire sur différents panneaux.

Voici quelques exemples pour illustrer ces notions.

Ajout de mesures dans votre partition

Une fois la palette de commande ouverte, renseignez en toutes lettres l’action recherchée : add

Assurez-vous que le préfixe recherché apparaisse en bleu, puis sélectionnez le préfixe add-bar avec la touche Tabulation, la touche Entrée, ou en cliquant dessus.

La mention bar-count apparaît désormais en italique.

Cela signifie que vous êtes invité à préciser le nombre de mesures que vous souhaitez ajouter. Renseignez simplement le nombre de mesures souhaité, ici 20 mesures.

Le préfixe add-bar est complété par le nombre de mesures indiqué.

Ici, votre commande finale est donc :

  • Commande = Préfixe + Argument
  • Commande = add-bar + (bar-count)
  • Commande = add-bar + 20
  • Commande = Add 20 bars

Vous pouvez valider la commande Add 20 bar(s) à l’aide de la touche Entrée ou en cliquant dessus.

20 mesures seront ajoutées à la partition en une seule fois.

Répétition de mesures

Sur le même principe qu’expliqué précédemment, sélectionnez le préfixe repeat bar(s).

Répétitions de mesures depuis la palette de commande

Vous êtes invité à préciser le nombre de mesures que vous souhaitez répéter.

Répétitions de mesures depuis la palette de commande

Indiquez le nombre de répétitions souhaitées. Puis validez la commande Repeat bar(s) 10 time(s) via la touche Entrée ou en cliquant dessus. Votre sélection sera répétée 10 fois.

Édition d’un bend

Sélectionnez le préfixe bend.

Ajout d’un bend depuis la palette de commande

Vous êtes invité à préciser la valeur du bend.

Plusieurs méthodes s’offrent à vous :

  • Renseignez directement la valeur du bend en toutes lettres (exemple : “bend 2”), puis validez avec la touche Entrée.
  • Cliquez directement sur la valeur souhaitée.
  • Utilisez les flèches haut et bas pour passer en revue les différentes valeurs, et entendre au passage le rendu sonore de chaque valeur. Validez avec la touche Entrée.
Ajout d’un bend depuis la palette de commande

L’application du bend sera immédiate après avoir validé la commande.

Compléter une commande via la touche Tabulation

Une fois votre préfixe renseigné, et en fonction de la commande souhaitée, vous aurez parfois la possibilité de compléter la commande avec d’autres arguments qui ne sont pas affichés d’emblée dans le premier panneau.

Le cas échéant, un petit pictogramme de tabulation apparaîtra sur l’une des entrées.

Pictogramme tabulation indiquant la possibilité de compléter la commande

Utilisez la touche Tabulation de votre clavier pour accéder au panneau suivant et compléter la commande, comme illustré dans l’exemple qui suit.

Édition de la clef

Sélectionnez la commande Set clef via le préfixe Clef.

Plusieurs choix de clefs apparaissent, la clef actuelle est indiquée.

Remarquez que l’icône de tabulation est affichée, vous indiquant la possibilité de compléter votre commande.

Utilisez la touche Tabulation pour accéder aux options suivantes et compléter votre commande davantage.

Utilisez à nouveau la touche Tabulation .

Et ainsi de suite jusqu’à obtention de la commande finale souhaitée.

Bien qu’il soit possible de compléter vos choix dans la palette de commande en utilisant la touche Entrée, la touche Tabulation, ou en sélectionnant la commande, nous vous recommandons de privilégier l’utilisation de la touche Tabulation afin de ne pas manquer certains arguments complémentaires quand ceux-ci sont disponibles. L’application de votre commande se fait en cliquant dessus ou en utilisant la touche Entrée.

Commandes et patterns

Certaines commandes avancées fonctionnent de pair avec l’application d’un pattern, c’est-à-dire une séquence qui peut être appliquée à votre partition.

Voici un exemple concret avec l’édition de coups de médiator vers le haut ou le bas depuis la palette de commande.

Ajout de coups de médiator haut et bas

Une fois vos notes éditées, placez votre curseur dans la première mesure. Puis ouvrez la palette de commande.

Recherchez ou renseignez le préfixe pickstroke, puis validez.

Le préfixe pickstroke est désormais complété par la mention pattern en italique, vous invitant à renseigner votre pattern.

Les indications pour l’édition du pattern sélectionné apparaissent toujours sous la barre bleue.

Édition de coups de médiator depuis la palette de commandes

Ici, renseigner un d équivaut à un coup de médiator vers le bas.

Renseigner un u équivaut à un coup de médiator vers le haut.

Utiliser la barre espace vous permet de laisser un espace vide.

Renseignez ces éléments dans la palette de commande, les temps sont édités les uns après les autres.

Édition de coups de médiator depuis la palette de commandes

Dans l’exemple ci-dessus, les éléments : dduddud ont été renseignés.

Soit coup de médiator vers le bas, bas, haut, bas, bas, haut, bas.

Il ne vous reste plus qu’à valider la commande Set pickstroke pattern à l’aide de la touche Entrée ou en cliquant dessus pour l’appliquer.

Édition de coups de médiator depuis la palette de commandes

Application d’un pattern à une sélection

Il est également possible d’appliquer votre pattern à une sélection de plusieurs mesures, voire sur toute votre piste.

Pour cela, sélectionnez les mesures concernées avant d’ouvrir la palette de commande, puis éditez votre pattern comme indiqué précédemment.

Votre pattern sera immédiatement indiqué sur votre sélection, comme illustré ci-dessous avec l’application d’un pattern brush haut et bas.

Application d’un pattern brush à la sélection

Le pattern ud s’applique à toute la sélection, et les indications brush haut et bas apparaissent immédiatement en une seule fois.

Il ne vous reste plus qu’à valider votre commande via la touche Entrée ou en cliquant dessus.

Voici la liste des commandes pour lesquelles il est possible d’appliquer un pattern, et les éléments d’édition du pattern concerné.

Préfixe Description Pattern
arpeggio Définir pattern arpeggio u = ↓ d = ↑ Espace = aucun
brush Définir pattern brush u = ↓ d = ↑ Espace = aucun
golpe Définir pattern golpe f = finger t = thumb Espace = aucun
left hand Définir pattern main gauche 0 1 2 3 4 T // - saute une note Espace saute un temps
picking Définir pattern picking automatique Alterné (haut et bas) ou Economy (même direction)
pickstroke Définir pattern coups de médiator u = ↓ d = ↑ Espace = aucun
right hand Définir pattern main droite p i m a c // - saute une note Espace saute un temps
slap pop pattern Définir pattern slap/pop s = slap p = pop Espace = aucun
wah Définir pattern wah-wah o = ouvert c = fermé Espace = aucun

Les possibilités d’utilisation de commandes sont très nombreuses, il serait compliqué de toutes les détailler dans ce guide.

Vous trouverez plus bas la liste des commandes qui peuvent être utilisées depuis la palette de commande.

Par défaut, la palette de commande se fermera automatiquement après avoir appliqué une commande. Cependant, vous avez la possibilité de la maintenir ouverte entre deux éditions en appliquant la commande Activate flow mode.

Recherches et filtres intelligents

Les résultats proposés dans la palette de commande seront basés sur les éléments que vous avez renseignés et s’affineront au fil de l’édition, comme illustré ci-dessous.

Recherche dans la palette de commande

Mais il n’est pas indispensable de connaître toute la liste des préfixes ou de les passer en revue pour obtenir l’action souhaitée.

En effet, vous pouvez simplement indiquer en toutes lettres l’élément recherché, et les différents préfixes liés à cet élément seront affichés, vous permettant d’accéder et d’exécuter la commande appropriée par la suite.

Par exemple, si vous souhaitez appliquer une nuance fortissimo à une sélection, vous pouvez indiquer en toutes lettres ff depuis la palette de commande.

Le préfixe dynamic apparaît, vous permettant d’accéder à la commande Set dynamic.

Confirmez votre choix.

Validez la commande (clic ou Entrée) pour appliquer cette nuance à votre sélection.

Ou encore, sur le même principe, si vous souhaitez exporter votre fichier au format XML, renseignez simplement la mention “xml”, les préfixes d’import et d’export XML vous seront suggérés, il ne vous reste plus qu’à compléter et valider votre commande.

Résumé

  • Accès depuis le menu Outils > Palette de commande ou Ctrl+E
  • ? affiche les commandes disponibles
  • La disponibilité d’une commande dépend de votre sélection
  • Tapez en toutes lettres tout ou partie du nom de l’action recherchée. Les commandes correspondantes vous seront suggérées
  • Sélectionner un préfixe donne accès à une commande
  • Les commandes rapides s’appliquent directement (préfixe)
  • Les commandes avancées impliquent de préciser l’action souhaitée (préfixe + argument(s))
  • Lors de la création d’une commande, les touches Tabulation et Entrée, ou un clic sur l’option proposée, vous permettent de compléter la commande
  • L’application d’une commande se fait à l’aide de la touche Entrée ou en cliquant sur la commande
  • L’icône Tabulation indique qu’il est possible de compléter la commande avec d’autres éléments
  • Une description ou des compléments d’informations apparaissent quand nécessaire (ex. : pattern)
  • La palette de commande est affichée en anglais, mais vous pouvez effectuer des recherches de préfixes dans votre langue si celle-ci est disponible dans Guitar Pro.

Liste des commandes rapides

Liste des commandes rapides qui peuvent être utilisées directement :

Préfixe Action
anacrusis Afficher anacrusis
crescendo Afficher crescendo
dead-note Afficher dead note
dead-slapped Afficher dead slapped
decrescendo Afficher decrescendo
double-barline Afficher double barre
double-simile Afficher double simile
fade-in Afficher fade-in
fade-out Afficher fade-out
force-break-line Forcer retour à la ligne
force-tuplet-bracket Afficher crochet tuplets
free-time Afficher temps libre
hammer-on-pull-off Afficher hammer-on/pull-off
left-hand-tapping Afficher tapping main gauche
legato Afficher legato
let-ring Afficher let ring
multirest Activer bâton de mesure
multivoice Activer multivoix
palm-mute Afficher palm mute
pedal Afficher pédale de sustain
prevent-break-line Empêcher retour à la ligne
print Imprimer partition
repeat-close Ajouter renvoi fin
repeat-open Ajouter renvoi début
rest Ajouter silence(s)
show-string-number Afficher le numéro de corde
simile Afficher simile
tapping Afficher tapping
tie-beat Lier temps
tie-note Lier note(s)
timer Afficher le chrono
volume-swell Afficher volume-swell

Liste des commandes avancées

Liste des commandes avancées qui nécessitent de renseigner un complément pour être utilisées.

Préfixe Action
$ Aller à la section
4/4 Régler l’armure
: Aller à la mesure
@ Afficher et déclencher des actions (voir Liste d’actions)
add-bar Ajouter mesure(s)
alternate-endings Régler les répétitions
arpeggio Définir pattern arpeggio
barre Ajouter barrés
barre-half Ajouter demi-barrés
bend Ajouter bend
bend-release Ajouter bend/release
brush Ajouter pattern brush
chord Ajouter accords
clef Régler clef
copy voice Copier vers une autre voix
direction Ajouter cibles et sauts pour directions
dynamic Ajouter nuances
export Exporter partition
fermata Appliquer fermata
find-scale Trouver gamme
flow Activer mode flow
focus Régler le focus de la piste en cours
free-text Insérer texte libre
golpe Définir pattern golpe
hide-tempo-automation Masquer automation de tempo
hold-bend Hold bend
import Importer des fichiers
insert-bars Insérer mesure(s)
key-signature Régler l’armure
left-hand-fingering Appliquer doigté main gauche
lyrics Ajouter paroles
master-pan Ajouter automation panoramique piste master
master-volume Ajouter automation de volume piste master
move-voice Changer de voix
n:m Régler tuplets personnalisés
octave-sign Indiquer changement octave (8va, 8vb, 15ma, 15mb)
ornament Appliquer ornement
pan Ajouter automation panoramique
picking-pattern Définir pattern picking ou sélection monophonique
pickstroke Définir pattern coups de médiator
playing-style Régler le style de jeu de la piste
prebend Ajouter prebend
prebend-bend Ajouter prebend/bend
prebend-release Ajouter prebend/release
rasgueado Définir rasgueado
relative-speed Régler la vitesse relative
relative-tonality Régler la tonalité relative
release-bend Ajouter release bend
right-hand-fingering Appliquer doigté main droite
select-bars Sélectionner mesures
select-section Sélectionner section
show-scale Afficher gamme sur le manche virtuel
show-tempo-automation Afficher automation de tempo
slap-pop Appliquer pattern slap/pop
stem-direction Définir orientation des hampes
swap-voices Inverser avec une autre voix
tempo Ajouter automation de tempo
transpose Transposer la sélection
tremolo-picking Appliquer tremolo picking
triplet-feel Appliquer triplet feel
unfocus Régler le défocus de la piste en cours
unset Désactiver élément
view Changer la vue
voice Changer la voix active
volume Ajouter automation de volume
wah Définir pattern wah-wah
x Répéter mesure(s)
zoom Zoom avant/arrière

Texte d’expression (musicale)

Subdivision de la palette de commande, la fonctionnalité Texte d’expression ou Texte d’expression (musicale) est accessible directement depuis le menu Outils > Texte d’expression, le raccourci clavier Shift E, ou encore via la palette de commande en renseignant un > dans le champ de recherche.

Accès Texte d’expression

Son fonctionnement est identique à la palette de commande, à ceci près qu’il n’est plus nécessaire d’utiliser un préfixe.

La fenêtre Texte d’expression vous permet d’éditer les éléments suivants :

  • les accords
  • les nuances
  • l’armure
  • les signes d’octave
  • la clef
  • les directions

Saisissez directement le nom de l’élément que vous souhaitez ajouter à votre partition (parmi les éléments listés ci-dessus), puis validez votre sélection.

Utilisation Texte d’expression

Liste d’actions

Autre subdivision de la palette de commande, la Liste d’actions est accessible directement depuis le menu Outils > Liste d’actions, le raccourci clavier Alt E, ou encore via la palette de commande en renseignant un @ dans le champ de recherche.

Accès à la liste d’actions

Celle-ci fonctionne comme un explorateur et vous permet de naviguer dans les différents menus et sous-menus de Guitar Pro, qui sont habituellement accessibles depuis le haut de votre fenêtre Guitar Pro (Windows) ou de votre écran (macOS), à savoir les menus :

  • Fichier
  • Édition
  • Piste
  • Mesure
  • Note
  • Effets
  • Section
  • Outils
  • Son
  • Affichage
  • Fenêtre
  • Aide

Les éléments indiqués vous permettent de déclencher les actions propres à chaque menu et sous-menu.

La liste d’actions fonctionne comme un filtre et va lister tous les résultats trouvés par rapport à ce que vous avez indiqué.

Par exemple, pour afficher la vue manche de guitare, habituellement accessible via le menu : Affichage > Afficher la vue : manche de guitare.

Indiquez simplement tout ou partie du nom de l’action souhaitée, ici manche, et le menu correspondant apparaît.

Action afficher la vue manche de guitare

Un autre exemple avec l’affichage multipiste.

Activer le multipiste depuis la liste d’actions